在parrot4.7下同时安装使用PHP7+和5.6的天坑

php

#1

本来在双系统中安装的是最新的PHP7.3,但是由于工作需要,所以加入了PPA安装了php5.6。


安装之后导致的问题

  1. 需要对libpcre3进行降级
    仓库中最新的版本为libpcre3=2:8.39,但是安装5.6需要的版本是libpcre3>=2.8.42。可以通过指定版本安装来临时解决这个问题,但是在apt full-upgrade或者parrot-upgrade之后,libpcre3会自动降级,然后php5.6相关的包会被自动理解为无效的包,可通过apt autoremove移除。

  2. 无法安装使用xdebug
    xdebug是个好东西,一直用一直爽,但是目前xdebug官方已经不再对7.0及以下版本进行维护,也就是说无法在人见人爱,可以直接贴进去phpinfo输出的内容进行解析的wizzard中使用,这样的话就只能去download页面手动下载源码编译,然后因为php我们是通过apt进行安装的,需要安装php5.6-dev才能手动进行phpize的编译,然后安装这玩意又要对大量的包进行降级。在看到长长的需要降级的包列表之后我直接放弃了。


不清楚是不是因为ppa的原因,如果有大佬尝试了其他PPA没有发生相关问题,请务必不吝赐教回复在下面或直接联系我~


#2

加个容器或者非FHS的包管理器来解决坑爹的环境问题


#3

不懂,大佬能仔细说说么


#4

把服务装容器里面


Partners Wiki IRC